Hi 您目前尚未登陆
请选择 进入手机版 | 继续访问电脑版

Admin

送给“上官雨伦”:做教师的人自己便当具有良好的教养,随人、随时、随地,都有适当的举止与礼貌。受过教育而无教养的人是一堆一文不值的垃圾。
演示站完全是自己仿的!所有帖子是胡乱发的,大家请无视!插件和模板都下载自垃圾的,没偷没抢!!!

Discuz! X3.4 升级至 Discuz! X3.5 详细教程 heatlevel

2020-04-25 18:20:59 发布

Discuz /[教程] 47 0 0

adminWriter

来自中国,不是教师

47

主题

48

帖子

48

积分

管理员

Rank: 9Rank: 9Rank: 9

积分
48
发表于 2020-4-25 18:20:59 | 显示全部楼层 |阅读模式
由于Discuz! X3.5 对数据库有很大的调整。所以单凭覆盖文件是无法实现对Discuz!的升级。由于相关操作有些多。在不熟练的情况下请谨慎操作。
注:操作前请备份数据

1. 进入您原来的系统,关闭您的站点。进行数据备份
2. 站点建立 old 文件夹,除 data, config, uc_server, uc_client 之外的文件移动到 old 目录中
3. 下载并解压缩最新版的程序包(请注意需要与您原来的语言版本一样,不可混用) 下载地址:https://gitee.com/ComsenzDiscuz/DiscuzX/tree/v3.5/
4. 上传upload目录中的程序到服务器论坛目录,如果提示需要覆盖,则选择“是”
5. 下载 https://gitee.com/oldhuhu/DiscuzX34235 将 scheme 文件夹放在 install 目录中
6. 下载 https://gitee.com/oldhuhu/DiscuzX34235/tree/dev/ 将 update_adult.php 文件放在 install 目录中
7. 访问 http://您的域名/install/update_adult.php
8. 按照程序提示,直至所有升级完毕。
9. old 目录中如果存放有非discuz程序文件(如模板、插件、自行修改的程序文件),则恢复到原来的位置
10. 进入论坛后台,更新缓存,并对新功能进行设置和测试。

主要:由于Discuz! X3.5的程序包中,没有更新/utilities/ 目录中的 update.php文件,所以切勿使用该文件升级数据库

    升级过程中,如果提示
#1227 - Access denied; you need the SUPER privilege for this operation

表明你需要超级权限来访问mysql,也就是说需要root账户。
    需要打开 /config/config_global.php 将
$_config['db']['1']['dbuser'] =
$_config['db']['1']['dbpw'] =


修改为你数据库的root账号和对应的密码

0 使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

当前话题还没有评论,来做第一个评论的人吧 ♪(^∇^*)